跳转至

About Apache Struts2

xxxxx

Vulnerability list

struts2-032_cmd.py Struts2 method 任意代码执行漏洞GetShell利用脚本(CVE-2016-3081)
struts2-032_poc.py Struts2 method 任意代码执行漏洞检测脚本(CVE-2016-3081)
struts2-045_cmd.py Struts2 Jakarta Multipart parser 插件远程命令执行漏洞利用脚本1(CVE-2017-5638)[使用]
struts2-045-2_cmd.py Struts2 Jakarta Multipart parser 插件远程命令执行漏洞利用脚本2(CVE-2017-5638)[使用]
struts2-052_cmd.py Struts2 REST 插件远程代码执行漏洞利用脚本(CVE-2017-9805)
struts2-052_webshell.py Struts2 REST 插件远程代码执行漏洞上传Webshell脚本(CVE-2017-9805)
struts2-053_cmd.py Struts2 Freemarker 标签远程执行命令漏洞利用脚本(CVE-2017-12611)
struts2-057_cmd.py Struts2 Namespace 远程代码执行漏洞利用脚本(CVE-2018-11776)

Readme

部分脚本文件使用说明,详细使用分析请参考vulnerability-list中的[使用] - VER: 漏洞影响版本,一般情况下不在影响范围的版本没有相关漏洞 - USE: 脚本文件使用说明,大部分写在了脚本里,执行即可见 - EXP: 脚本利用示例,以及执行效果 - DES: 部分特殊脚本文件的特殊描述


最后更新: 2021-02-19